Jump to content
OpenRCT2
monsterrideop

Install on Linux from CD

Recommended Posts

So I followed the Quickstart guide for Linux, specifically the Manual Extraction - Retail CD option, and as I am running OpenSuSE Tumbleweed I have installed OpenRCT2 via Yast.

So I tried to run the game. I was asked to select my install folder and did so. I received a number of errors and had no music. I looked into the directories made via the quickstart and found that I had a Data/Data directory, containing css##.dat files. Not thinking this was correct I moved said files up one level into the first Data directory. Restarting OpenRCT2 I now had music, but still a crapton of errors. A portion of those are shown below, there are so many it filled 1000 line scrollback.

[BENCHSTN] Object not found.
[LAMPPIR ] Object not found.
[LITTERMN] Object not found.
[LITTERWW] Object not found.
[SCGABSTR] Object not found.
[SCGFENCE] Object not found.
[SCGGARDN] Object not found.
[SCGCLASS] Object not found.
[SCGJUNGL] Object not found.
[SCGJURAS] Object not found.
[SCGINDUS] Object not found.
[SCGMINE ] Object not found.
[SCGORIEN] Object not found.
[SCGSHRUB] Object not found.
[SCGPATHX] Object not found.
[SCGPIRAT] Object not found.
[SCGSIXFL] Object not found.
[SCGTREES] Object not found.
[SCGWALLS] Object not found.
[SCGWATER] Object not found.
[SCGWWEST] Object not found.
[SCGEGYPT] Object not found.
[SCGMEDIE] Object not found.
[PKEMM   ] Object not found.
[WTRCYAN ] Object not found.
Unable to load park: /home/chris/space/RCT2/Scenarios/Six Flags Magic Mountain.SC6
Failed to load: "/home/chris/space/RCT2/Scenarios/Six Flags Magic Mountain.SC6" for the title sequence.
Unable to load any parks from rct2.
Unable to play any title sequences.
[BALLN   ] Object not found.
[BURGB   ] Object not found.
[CNDYF   ] Object not found.
[ATM1    ] Object not found.
[ARRT1   ] Object not found.
[DOUGH   ] Object not found.
[DRNKS   ] Object not found.
[LIFT1   ] Object not found.
[FAID1   ] Object not found.
[INFOK   ] Object not found.
[ZLDB    ] Object not found.
[LFB1    ] Object not found.
[MGR1    ] Object not found.
[RBOAT   ] Object not found.
[TLT1    ] Object not found.
[TWIST1  ] Object not found.
[VCR     ] Object not found.
[PTCT1   ] Object not found.
[COOKST  ] Object not found.
[CIRCUS1 ] Object not found.
[COFFS   ] Object not found.
[DODG1   ] Object not found.
[ENTERP  ] Object not found.

I'm thinking that I missed something on the install or possibly my CD is no good.

Any ideas?

Share this post


Link to post
Share on other sites

I think you’re missing the JSON objects, which should come with OpenRCT2. How did you install OpenRCT2? What do you see at startup?

Share this post


Link to post
Share on other sites

Thanks for the hint jensj12 and sorry for the late reply, looks like only 1 post per day for the newbies directly after the first one.

To answer you questions, although it is already solved, I installed OpenRCT2 via the OpenSuSE package manager, YAST, and I saw the four buttons plus exit and options but no demo park in the background. With the JSON issue in mind I downloaded OpenRCT2 from the website and did some sleuthing.

After comparing the Data directories from the download and my installed version it looks like the object directory is missing in it's entirety, which of course is where all the JSON object files are stored. Copying over said directory to where it should be in my installed version got everything working.

I have submitted a bug on the OpenSuSE bugzilla, #1120400, so if anyone else has this issue on OpenSuSE they can help to push to have the problem fixed.

Edited by monsterrideop
  • Informative 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×