Jump to content
OpenRCT2
ChookFowler

Original Maze Problems in RCT1

Recommended Posts

I have installed RCT1 from the UK cd.  Every time I pull up one of the two original mazes (Mini Maze and Spiral Maze) they are corrupted (impossible to solve with walls all over the place) and the entrance and exit does not go directly into the maze.  These two mazes cannot be rotated.  They appear to rotate on the ride window but they never actually rotate when you place them.

All the other mazes work fine.  It is just the two original ones from the game.

I have tried copying the files for the mazes from another rides source, I have changed the read only status, and I have also copied the files again from the US version of the cd.  The mazes are still appearing corrupted.  The CDs are originals purchased when the game was first released. 

When I play RCT1 as a stand alone game they are fine.  I have attached screen shots from RCT1 and OpenRCT2.  The current build shot is also attached.

As you can see, the entrance and exit are facing the wrong way and when the people enter (from the rear side), they are all stuck at the front unable to go anywhere.  I have also changed the front path type to standard path and have even left it as grass.  They still just stand there jumping up and down like they are inside the maze but unable to move.

I have only just discovered OpenRCT2 so this is the only build I have ever used and apart from this I have not found any other problems whatsoever.

[Edit:  I just tried another maze in a saved game and it was also corrupted - photo attached.  This maze appeared fine and worked when I replaced it in the game the second photo was taken from.  This maze also suffers from the rotate problem as well.  I have gone back to a new Leafy Lake scenario and after building and demolishing multiple mazes it appears that sometimes they are all corrupted and sometimes they all work fine, even the original ones that gave me the problems.]

After playing with this a little longer I have discovered that the mazes only seem to want to work in one single orientation.  If you rotate them and look at the ghost image, you can see the orientation where the maze is not corrupted.

 

RCT1 mazes.JPG

OpenRCT2 maze.JPG

OpenRCT2 build.JPG

OpenRCT2 alt maze corrupted.JPG

Edited by ChookFowler
Further info on bug.

Share this post


Link to post
Share on other sites

For me this seems to happen with all mazes, not just those two from the original game. Mini Maze is known to have issues, it previously caused crashes.

This looks like an issue with the rotation. Each of the pieces gets rotated, but not the entire track. There should be one rotataion where the maze looks fine.

  • Like 1

Share this post


Link to post
Share on other sites

Yes, that's how vanilla RCT2 has it too. It may be possible that a mistake was made during the refactoring, making a ride not have a flag to allow them having music. In theory all rides are able to play music, it's just not possible to set them to in all cases.

  • Informative 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×