Jump to content
OpenRCT2
okamzikprosim

Way to reset Window Scale Factor

Recommended Posts

Instead of making the factor larger, I accidentally made it smaller and now the game is next to unplayable because I cannot read the menus. Is there a way to reset the window scale factor?

Share this post


Link to post
Share on other sites

I have changed the window scale back to 1.0 in the config.ini in Application Support/OpenRCT2. However, the game still does not scale properly. I'm using a Retina 4K iMac. (Scale of 0.5 just makes the screen blurry.)

268372214_ScreenShot2019-03-14at17_26_54.thumb.png.1a0cd7d938648e0987394cd50dcb5f08.png

Edited by JaydenIrwin

Share this post


Link to post
Share on other sites

I'm having the exact same problem with my 2015 MacBook Pro Retina 13". The buttons seem to be in the right place but its like the screen has been zoomed in. I've checked the config file and mine is already set to 1.0000 


I've tried both the Stable Release and the Developer Release and get the same issue each time. 

Screenshot shows what game looks like when it opens. I have also used Quicktime to record opening the program.

Screen Shot 2019-03-14 at 6.20.19 PM.png

Edited by jr_grzy
Upload screenshot

Share this post


Link to post
Share on other sites

We have had more people report this. However, it's hard to investigate unless we know the exact develop build in which it broke.

Share this post


Link to post
Share on other sites

I have the same problem on an iMac 5K. The higher pixel density seems to be ignored, so I only see the left bottom corner of the screen (just like jr_grzy's and JaydenIrwin's screenshot).

It got broken somewhere after 12-03-2019 (March 12). That's the last time I played it without this problem.

Edited by bbb

Share this post


Link to post
Share on other sites

It looks like we might have found the cause (a bug in a third-party library). There is no timescale for when it will be fixed yet.

Share this post


Link to post
Share on other sites

Is there a quick/temporary client-side fix, or an ETA for when this may be resolved? I just downloaded the game the other day and opened it to the same result as the previous comments. Running on a 2015 Macbook Retina 13" with the latest software. 

Share this post


Link to post
Share on other sites

Setting the game to use OPENGL rendering is a workaround. Go to Library -> Application Support -> OpenRCT2, edit config.ini and set drawing_engine to OPENGL

  • Like 2

Share this post


Link to post
Share on other sites

You're welcome!

By the way, this should now have been fixed. If you like, you can now put the game back on software rendering mode (OpenGL mostly works fine, it sometimes has minor bugs and it cannot yet draw previews of track designs, but that's about it).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...